SPELL does not show up in my Metamask wallet

I transferred SPELL to my MetaMask wallet. The transaction shows up on etherscan.io but does not show up in MetaMask. Still waiting for response from MM but taking forever. I try to import tokens to ETH/MM and it just spins forever, never loading them. Searched everywhere for help and all say the same thing.

In MetaMask main asset list, scroll down to the bottom and click Import Tokens. A search screen will appear, select custom token. In the token address field enter the contract address:


The other fields will automatically populate. Click import and the token should now be viewable on your main asset page. If this didn’t solve your issue please provide more information, good luck.

Already tried that multiple times. When I add the address the other fields do not populate. I have to manually input them. Still does not work. It just spins acting like it is thinking and nothing happens. Not sure what else I can tell you.

I uninstalled MM and reinstalled. It worked! What a pain in the ***

Thanks for your help b_zemo.

Glad it worked out, cheers mate!